Воскресенье, 11.12.2016, 00:23
| RSS
Главная | Контроллер RS485 - Страница 2 - Форум
Защита, контроль, управление
Форма входа
Логин:
Пароль:
[ Новые сообщения · Участники · Правила форума · Поиск · RSS · Чат ]
Страница 2 из 33«12343233»
Модератор форума: Zoolu 
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Контроллер RS485
Контроллер RS485
jonДата: Четверг, 20.11.2014, 22:37 | Сообщение # 11
Группа: Пользователи
Сообщений: 67
Статус: Offline
Надписи (Отключен) не должно быть, а должен быть серый фон судя по вашему объяснению.
 
AdminДата: Четверг, 20.11.2014, 22:46 | Сообщение # 12
Admin
Группа: Администраторы
Сообщений: 3200
Статус: Offline
Значит где-то при последней сборке интерфейса не доглядел, нужно исправлять.
Сейчас у себя отключил питание от этого контроллера, действительно на первом выходе на сером фоне надпись "Отключен".
Все это несущественно, я ведь сразу отметил - если фон кнопок серый и надпись на сером "Disconnect" - ищите проблему в RS485/
Так что насчет сетевого адреса контроллера?
 
jonДата: Четверг, 20.11.2014, 22:51 | Сообщение # 13
Группа: Пользователи
Сообщений: 67
Статус: Offline
Сетевой адрес-61
Прикрепления: 0259362.jpg(23Kb)
 


AdminДата: Четверг, 20.11.2014, 22:54 | Сообщение # 14
Admin
Группа: Администраторы
Сообщений: 3200
Статус: Offline
Так, все правильно. Тем более, как мы выяснили выше, управление каналами с web интерфейса проходит. Значит, см. сообщение №6
 
jonДата: Четверг, 20.11.2014, 23:08 | Сообщение # 15
Группа: Пользователи
Сообщений: 67
Статус: Offline
Что-то я совсем запутался. Не смотря на то что я могу управлять выходом 1 (включать и выключать) выходит связи нет ?

Ps: С первоначальной прошивкой и старым интерфейсом все работает (без датчиков температуры)


Сообщение отредактировал jon - Четверг, 20.11.2014, 23:22
 
AdminДата: Пятница, 21.11.2014, 05:40 | Сообщение # 16
Admin
Группа: Администраторы
Сообщений: 3200
Статус: Offline
Ну я же объяснял, что скорее всего нет связи "в одну сторону" . Поймите, RS485 двухнаправленный! И получается возможно следующее - послали команду, контроллер ее принял, обработал, включил канал, а обратную сигнализацию состояния не выдал. 

Но при таком раскладе, должны управляться все выходы, а не только первый. В общем, сегодня вечером постараюсь еще раз все проверить.
 
AdminДата: Пятница, 21.11.2014, 20:34 | Сообщение # 17
Admin
Группа: Администраторы
Сообщений: 3200
Статус: Offline
Итак, констатирую факт - jon прав smile
Отключил оба датчика (DHT22 и DHT11) и обратная сигнализация от контроллера не проходит. Подключаю DHT22 - все начинает работать.
Так быть не должно! Но почему так происходит - пока не отвечу. Буду разбираться. Похоже, что проблема на стороне контроллера.
 
jonДата: Пятница, 21.11.2014, 20:37 | Сообщение # 18
Группа: Пользователи
Сообщений: 67
Статус: Offline
Желаю удачи!
 
AdminДата: Суббота, 22.11.2014, 20:31 | Сообщение # 19
Admin
Группа: Администраторы
Сообщений: 3200
Статус: Offline
jon, проверяйте прошивку контроллера. Проблема была в том, что без датчиков в регистры передачи данных записывались случайные значения и web сервер не мог их правильно "переварить". Сейчас в эти регистры при отсутствии датчиков записываются нулевые значения.

Прошивку в общем архиве так же обновил.
Прикрепления: control_adr.zip(3Kb)
 
jonДата: Воскресенье, 23.11.2014, 08:49 | Сообщение # 20
Группа: Пользователи
Сообщений: 67
Статус: Offline
К сожалению ни чего не изменилось . Единственное  то что теперь при включении на всех выходах высокий уровень
Прикрепления: 3205335.jpg(69Kb)
 
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Контроллер RS485
Страница 2 из 33«12343233»
Поиск:



T2M © 2016
Сайт управляется системой uCoz