Суббота, 20.04.2019, 15:07
| RSS
Главная | Raspberry Pi. Общие вопросы. Часть 3 - Страница 72 - Форум
Защита, контроль, управление
Форма входа
Логин:
Пароль:
[ Новые сообщения · Участники · Правила форума · Поиск · RSS · Чат

Наш новый сайт - https://whp.home.blog
]
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Raspberry Pi. Общие вопросы. Часть 3
Raspberry Pi. Общие вопросы. Часть 3
AdminДата: Среда, 20.09.2017, 07:05 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 4170
Статус: Offline
Продолжение темы. Предыдущие темы форума по общим вопросам системы домашней автоматизации смотрите здесь:

Часть первая
Часть вторая
Чат Телеграмм

Наша группа в Facebook. Присоединяйтесь!


Сообщение отредактировал Zoolu - Суббота, 03.03.2018, 17:58
 
ppwwddДата: Вторник, 08.01.2019, 19:36 | Сообщение # 711
Группа: Пользователи
Сообщений: 427
Статус: Offline
ADMIN, попробую завтра с утра. Сейчас на работе.
 


ppwwddДата: Вторник, 08.01.2019, 19:58 | Сообщение # 712
Группа: Пользователи
Сообщений: 427
Статус: Offline
admin, пробую на работе. Вот что получилось. Нужны библиотеки.

Добавлено (08.01.2019, 20:00)
---------------------------------------------
библиотеки,  которые я использовал когда компилировал дома, наверное не годятся. Сейчас я быстренько установил ARDUINO IDE, но наверное нужны подходящие библиотеки.

Прикрепления: 0088800.png(44.6 Kb) · 3234363.png(36.2 Kb)
 
AdminДата: Вторник, 08.01.2019, 20:03 | Сообщение # 713
Admin
Группа: Администраторы
Сообщений: 4170
Статус: Offline
У Вас версия Arduino IDE 1.6.5, я использую 1.8.1. Возможно, в этом проблема.
 
ppwwddДата: Вторник, 08.01.2019, 20:05 | Сообщение # 714
Группа: Пользователи
Сообщений: 427
Статус: Offline
Попробую установить 1.8.1
 
ppwwddДата: Вторник, 08.01.2019, 20:28 | Сообщение # 715
Группа: Пользователи
Сообщений: 427
Статус: Offline
С версией 1.8.1
Прикрепления: 8223657.png(30.3 Kb)
 
AdminДата: Вторник, 08.01.2019, 20:40 | Сообщение # 716
Admin
Группа: Администраторы
Сообщений: 4170
Статус: Offline
А Вы вообще дополнительные библиотеки для ESP в среду Arduino IDE подгружаете?
Информация - https://habr.com/post/371853/
 


ppwwddДата: Вторник, 08.01.2019, 21:02 | Сообщение # 717
Группа: Пользователи
Сообщений: 427
Статус: Offline
ADMIN, если бы я знал какие дополнительные библиотеки нужно подгружать. Я с трудом понимаю какие основные нужно, не то что дополнительные.
 
AdminДата: Вторник, 08.01.2019, 21:10 | Сообщение # 718
Admin
Группа: Администраторы
Сообщений: 4170
Статус: Offline
Просто сделайте все как в инструкции по ссылке выше:

1. Запускаем среду разработки и тут же идём в Файл/Настройки:
2. Вставляем ссылку в поле «Дополнительные ссылки для Менеджера плат:» и жмём «OK».
и т.д.
 
ppwwddДата: Вторник, 08.01.2019, 21:17 | Сообщение # 719
Группа: Пользователи
Сообщений: 427
Статус: Offline
ADMIN, так это сделано с самого начала. Еще до компиляции. 
Еще одна проба.
Прикрепления: 5331898.png(30.4 Kb)
 
AdminДата: Вторник, 08.01.2019, 21:27 | Сообщение # 720
Admin
Группа: Администраторы
Сообщений: 4170
Статус: Offline
Цитата ppwwdd ()
так это сделано с самого начала. Еще до компиляции. 

Т.е. "esp8266 by ESP8266 Community" установлено?

Цитата ppwwdd ()
Еще одна проба.

Ругается, что отсутствует некий файл в директории. Я не очень хорошо знаком с этой средой программирования, поэтому затрудняюсь что-либо еще советовать. Нужно искать решение проблемы на профильных форумах.
В любом случае проблема тут в настройках самой Arduino IDE
 
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Raspberry Pi. Общие вопросы. Часть 3
Поиск:



T2M © 2019
Сайт управляется системой uCoz