Воскресенье, 18.08.2019, 07:17
| RSS
Главная | Глюки и Баги Raspberry Pi и WebHomePi. Проблемы и решения. - Страница 8 - Форум
Защита, контроль, управление
Форма входа
Логин:
Пароль:
[ Новые сообщения · Участники · Правила форума · Поиск · RSS · Чат

https://www.facebook.com/groups/463937897339644
]
  • Страница 8 из 9
  • «
  • 1
  • 2
  • 6
  • 7
  • 8
  • 9
  • »
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Глюки и Баги Raspberry Pi и WebHomePi. Проблемы и решения.
Глюки и Баги Raspberry Pi и WebHomePi. Проблемы и решения.


AdminДата: Среда, 16.01.2019, 15:27 | Сообщение # 71
Admin
Группа: Администраторы
Сообщений: 4202
Статус: Offline
Цитата starletovod ()
sudo /etc/init.d/webiopi start

Какая версия WHP используется?
На версиях WHP, построенных на Raspbian Stretch немного иначе:
sudo systemctl start webiopi

И давайте посмотрим ошибки:
sudo webiopi -d -c /etc/webiopi/config
 
starletovodДата: Четверг, 17.01.2019, 08:47 | Сообщение # 72
Группа: Пользователи
Сообщений: 5
Статус: Offline
WHP никакой не использую

использую пример от сюда: https://sites.google.com/site/webstm32/internet_rozetka
для установки webiopi пользовался патчем отсюда: https://github.com/doublebind/raspi

кардинальной разницы между WHP и тем что я использую - нет

реакция на команды "sudo /etc/init.d/webiopi start" и "sudo systemctl start webiopi" совершенно одинаковые

ошибки:


 
AdminДата: Четверг, 17.01.2019, 09:17 | Сообщение # 73
Admin
Группа: Администраторы
Сообщений: 4202
Статус: Offline
Цитата starletovod ()
WHP никакой не использую

Я выше уже давал ссылку – "чистый" фреймворк WebIOPi не поддерживает работу с новыми операционными система Raspbian. Там же подробно рассказано, что нужно сделать для адаптации WebIOPi под Stretch.

Цитата starletovod ()
кардинальной разницы между WHP и тем что я использую - нет

- Суслика видишь?
- Нет!
- А он есть! (С)
 
starletovodДата: Четверг, 17.01.2019, 10:43 | Сообщение # 74
Группа: Пользователи
Сообщений: 5
Статус: Offline
перезалил вэбиопу снова, как указано в https://github.com/doublebind/raspi

всё заработало

извините за беспокойство со стороны не ВХПшника wink
 
AdminДата: Четверг, 17.01.2019, 10:54 | Сообщение # 75
Admin
Группа: Администраторы
Сообщений: 4202
Статус: Offline
Цитата starletovod ()
всё заработало

Только после обновления ОС проблема может повториться.

Цитата starletovod ()
не ВХПшника

А у нас тут нет деления по приходам и епархиям biggrin
 
v193073Дата: Четверг, 18.07.2019, 14:04 | Сообщение # 76
Группа: Пользователи
Сообщений: 9
Статус: Offline
Здравствуйте, подскажите пожалуйста у меня не загружается Webiopi.....статус ошибки показывает следущее =(спойлер), 

не могу понять как запустить Webiopi........что нужно делать?
 
AdminДата: Четверг, 18.07.2019, 17:07 | Сообщение # 77
Admin
Группа: Администраторы
Сообщений: 4202
Статус: Offline
Цитата v193073 ()
у меня не загружается Webiopi

А если немного конкретизировать? "Чистый" WebIOPi, или WebHomePi? Если второй вариант, то какая версия? На какой малине?

Цитата v193073 ()
статус ошибки показывает следущее =(спойлер), 

под спойлером кроме команды на запуск отладки, больше ничего нет
 


v193073Дата: Понедельник, 22.07.2019, 10:14 | Сообщение # 78
Группа: Пользователи
Сообщений: 9
Статус: Offline
пока что у меня стоит "Чистый" WebIOPi 
статус ошибки ---

 pi@raspberrypi:~ $ sudo webiopi  /etc/webiopi/configTraceback (most recent call last):

  File "/usr/lib/python3.7/runpy.py", line 183, in _run_module_as_main

    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)

  File "/usr/lib/python3.7/runpy.py", line 142, in _get_module_details

    return _get_module_details(pkg_main_name, error)

  File "/usr/lib/python3.7/runpy.py", line 109, in _get_module_details

    __import__(pkg_name)

  File "/usr/local/lib/python3.7/dist-packages/WebIOPi-0.7.1-py3.7-linux-armv7l.        egg/webiopi/__init__.py", line 20, in <module>

    from webiopi.utils.thread import runLoop

  File "/usr/local/lib/python3.7/dist-packages/WebIOPi-0.7.1-py3.7-linux-armv7l.        egg/webiopi/utils/thread.py", line 36

    def runLoop(func=None, async=False):

                               ^

SyntaxError: invalid syntax

pi@raspberrypi:~ $
 
AdminДата: Понедельник, 22.07.2019, 14:23 | Сообщение # 79
Admin
Группа: Администраторы
Сообщений: 4202
Статус: Offline
Питон 3.7? А это не ваш случай? - https://github.com/tomato42/tlslite-ng/issues/214
 
v193073Дата: Вторник, 23.07.2019, 08:51 | Сообщение # 80
Группа: Пользователи
Сообщений: 9
Статус: Offline
....я так понял что Python 3.7 сырая и в ней могут быть глюки с webiopi, но всё же мне кажется что в sudo nano /etc/webiopi/config можно поменять настройки портов (точнее переименовать как нибудь?)   так как usb0 = serial по умолчанию занят  дисплеем, а мне нужно подключить RS485 ......
.....я хочу поработать с modbus rtu в  программе  Node_Red .....раз уж с Webiopi связи нет.
подскажите пожалуйста как порты перенастроить?


Сообщение отредактировал v193073 - Вторник, 23.07.2019, 08:53
 
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Глюки и Баги Raspberry Pi и WebHomePi. Проблемы и решения.
  • Страница 8 из 9
  • «
  • 1
  • 2
  • 6
  • 7
  • 8
  • 9
  • »
Поиск:



T2M © 2019
Сайт управляется системой uCoz