Пятница, 09.12.2016, 19:20
| RSS
Главная | Устройство управления и контроля. Часть 1 (тема закрыта) - Страница 15 - Форум
Защита, контроль, управление
Форма входа
Логин:
Пароль:
[ Новые сообщения · Участники · Правила форума · Поиск · RSS · Чат ]
Страница 15 из 100«12131415161799100»
Форум » ФОРУМ » Электроника для дома » Устройство управления и контроля. Часть 1 (тема закрыта)
Устройство управления и контроля. Часть 1 (тема закрыта)
AdminДата: Вторник, 18.10.2011, 22:38 | Сообщение # 141
Admin
Группа: Администраторы
Сообщений: 3195
Статус: Offline
Действительно, что-то меня немного заклинило, спутал с SIM900 (без буквы) biggrin
А SIM900D это полный аналог, всё правильно....
 
jonДата: Вторник, 18.10.2011, 22:39 | Сообщение # 142
Группа: Пользователи
Сообщений: 67
Статус: Offline
В EEPROM все прописывается, а соединения все равно нет и с новой прошивкой.
 
AdminДата: Вторник, 18.10.2011, 22:55 | Сообщение # 143
Admin
Группа: Администраторы
Сообщений: 3195
Статус: Offline
Тогда давайте начнём с самого начала. Если модуль запускается, с питанием микроконтроллера должно всё быть ок и всё же проверьте, сколько там. Должно быть около 4,3В. Далее необходимо проверить передачу сигналов от USART контроллера на GSM модуль. Сделать это лучше всего в терминальной программе, подключившись через согласующее устройство на МАХ3232.
 


jonДата: Суббота, 22.10.2011, 14:01 | Сообщение # 144
Группа: Пользователи
Сообщений: 67
Статус: Offline
Скрины при включении модуля и при попытке соединения.
Напряжение 4,2в.
Прикрепления: 1720045.jpg(41Kb) · 1616105.jpg(62Kb)
 
AdminДата: Суббота, 22.10.2011, 14:39 | Сообщение # 145
Admin
Группа: Администраторы
Сообщений: 3195
Статус: Offline
Ну всё понятно. Модуль не переключился для работы на скорости 19,2 кбит\сек. Попробуйте это сделать принудительно через терминальную программу и сохраните настройки:

AT+ IPR=19200
AT&W


Похожая проблема была рассмотрена в соседней ветке - GSM модуль на базе SIM300D
 
jonДата: Суббота, 22.10.2011, 15:54 | Сообщение # 146
Группа: Пользователи
Сообщений: 67
Статус: Offline
Что-то я не так делаю?
Прикрепления: 9179148.jpg(70Kb)
 
AdminДата: Суббота, 22.10.2011, 16:59 | Сообщение # 147
Admin
Группа: Администраторы
Сообщений: 3195
Статус: Offline
Да нет, всё правильно делаете, вижу, что модуль переключился на 19,2. Теперь всё должно работать. А какая прошивка залита, с прописаным количеством вызовов и паролем 1234?
 
jonДата: Суббота, 22.10.2011, 17:10 | Сообщение # 148
Группа: Пользователи
Сообщений: 67
Статус: Offline
Считаный HEX
Прикрепления: 1_0_mem.hex(45Kb)
 


AdminДата: Суббота, 22.10.2011, 17:16 | Сообщение # 149
Admin
Группа: Администраторы
Сообщений: 3195
Статус: Offline
Теперь уже и затрудняюсь что-либо ответить. Проверьте на всякий случай линию ТX модуля---->RХ микроконтроллера. Если всё ОК, то попробуйте чуть-чуть поднять питание, но не более 4,4В!
 
jonДата: Суббота, 22.10.2011, 18:55 | Сообщение # 150
Группа: Пользователи
Сообщений: 67
Статус: Offline
Питание 4,36v . при 4.6v накрылась SIM карта,модуль остался жив,но соединения нет
Прикрепления: 1776752.jpg(63Kb)
 
Форум » ФОРУМ » Электроника для дома » Устройство управления и контроля. Часть 1 (тема закрыта)
Страница 15 из 100«12131415161799100»
Поиск:



T2M © 2016
Сайт управляется системой uCoz